(i should probably just add support for mastodon style polls to ktistec...)

i have an informal poll for ktistec users. should we require (and use features from) the most recent versions of sqlite? how recent is too recent? if you're running ktistec, i'd love your point of view.

some background... sqlite is the most significant dependency in ktistec. to minimize problems for potential users, i intentionally stuck to features found in "older" versions of sqlite. as i write this, the current version of sqlite is 3.40.0.  ktistec only depends on 3.11.0, which was released in 2016. that's very conservative.

#ktistec

@toddsundsted
While I'm not a current user, I'm interested...(and hoping for a Yunohost install version.) Maybe just go back one previous version. Like 3.3xxx

@toddsundsted I vote that newer is OK, especially given that at least Ubuntu 22.04 LTS is on 3.37 and Alpine 3.17 is on 3.40. Especially since it gets `RETURNING ...` from 3.35 :)